Site news

Moodle Browser Requirements

 
Picture of Theodis Garth
Moodle Browser Requirements
by Theodis Garth - Monday, September 17, 2018, 11:01 AM
 

Browser Requirements

We recommend using a recent version of Firefox or Chrome. While Safari and IE may be fine for viewing Moodle resources, we don't recommend using these browsers for submitting assignments or taking tests in Moodle. We also recommend a high speed Internet connection for best performance.

Free Download to Chrome

Free Download to Firefox